BattleTech Save Editor

thanks yous

must be a issue with the new update

Sharing my experience. The save game editor works great, I play on Game Pass so the saved game directory is different. It’s located here:

C:\Users<username>\AppData\Local\Packages\ParadoxInteractive.Battletech-MainGame_zfnrdv2de78ny\SystemAppData\wgs<some crazy number e.g. 00090000006AC086_00000000000000000000000071658B80><e.g. another crazy number 3A7E7C2D02034F6884CFCDAE5147A887>

I make a save game, then sort the files. I make a copy of the latest file that is not the container file. There are no extensions on the save game file. Add a .sav extension to the latest file. I can then load it with the save editor.


Make your changes in the save editor, then save the file with the .sav. Remember to go back into the directory and remove the .sav extension. If you load the game without changing the extension it deletes the files and creates a new save and you have to do it all over again. (It would be great if the editor had an option to choose any file as well).

Also, remember to do this when the game is not running.

I have not found the JSON files.

I think I found the json files here:


but the editor does not seem to work with it.

Roguetech has been updated and using this tool now breaks my save files.

I love this tool and thank everyone involved in its creation and continued development.

Two requests:

  1. Update it to support 1.8.1-686R
  2. Allow us to add vehicles and battle armor like we can with mechs.


You’ll need to be more specific on what you are trying to do that causes a break?

I used it fairly regularly during the latest RT development, as did others. Keep in mind that the latest RT release changed a huge number of item IDs, so if you are trying to add old IDs that will break your save.

As for your other requests:

  1. It supports the latest (and likely final) 1.9.1 Release. There are not any real changes to the save structure between 1.8.1 & 1.9.1 so it should already work on that version.
  2. I do eventually want to add support for adding vehicles and BA, just haven’t had the time to do so yet.

Ok, now, with shame, as I appear to be one of THOSE players. Yesterday, after the game update I started a new game and tried to do an edit. The game failed to load after that complaining that I needed to upgrade Roguetech to a new version (as if the editor backdated the save file triggering the error). However, pulling it up today to grab a screenshot of the error to provide you, it worked.

So, with my head hung low and a tear in my eye of shame, I apologize for being one of those gamers with my head up my preverbal dark smelly orifice.

Thank you, JamieWolf. And may the gods of Solaris grant you some extra time to continue work on your fine editor.

Hello all!

Love this mod but I ran into an odd issue and was looking for advice. I used the editor to add structure items to my save, which was successful. However, I can’t use any structure item when in the mechlab refit window as none of them actually appear.

Oddly, armors do not have this issue, and the structure items themselves do appear in my in-game inventory.

In any case, any help or suggestions are appreciated! Thanks!

So, is there a way to fix this thing after it breaks your saves? I know it says backup your saves before using it. I figured that only be the save i edited. But, after using it on 1 save, /none/ of the saves I have will load anymore. I have 4 different saves for the campain, only 1 was edited now none of them will open, they just sit on the twirling load screen indicant of a broken save.

[s]The game always fails to load the edited files.
i load the save file into the editor, use the scan button, make the changes and save the file, but it won’t load ingame.
i tried editing cash and pilot stats (first both at once, later only cash.
the editor log file doesn’t list anything unusual, no errors or anything, aside from successfully autofixing the jsons of one of the mods i’m using.

all the other (unedited) saves work just fine and i also made a backup, so that’s not a problem.
i’m not using roguetech, nor BTA. i also don’t have any of the three main DLCs.[/s]

edit: whoops, didn’t read the last paragraph, still had the game open while editing

I cannot make sense of the “Scan” step. I am using BTA 3062, and I cannot find any save files made with the mod, nor can I find where to have the editor “Scan.” I can only flail around and try to find a place which does not tell me “Could not located JSON assets” - does anyone have a fix for this?

Where did you find the correct folder?

the folder to scan is the game folder where you find battletech.exe.

I use Steam, so the following:

Save Games: C:\Program Files (x86)\Steam\steamapps\common\BATTLETECH\BTASaves\cloud\C0\SGS1
Game Folder To Scan: C:\Program Files (x86)\Steam\steamapps\common\BATTLETECH